DaDaBIK
This forum is devoted to the discussion about the software DaDaBIK database front-end
the PHP Database application generator for MySQL, PostgreSQL and SQLite; also available for Wordpress.

Welcome! Log In Create A New Profile

Advanced

Error [08]

Posted by Manfred Eggers 
Manfred Eggers
Error [08]
March 14, 2004 12:19AM
After I reinstalled the new 3.0 beta version, two of my tables work well. However some other tables present an error message

>[08] Error: during query execution.

This is although I can see them in the admin page and i can aslo use the table admin .

Has someone any clue on it.

Regards

Manfred
Manfred Eggers
Re: Error [08]
March 14, 2004 04:12PM
I was too fast with my question.

The problem was that my tables had blank spaces in the name of it.
Dadbik 2.2.1 faced no prblem with it, but 3.0 does.

So I used xxx_xxx instead and it worked.

Manfred
Debbie Sontag
Re: Error [08]
March 15, 2004 09:48PM
I'm getting this error on all the tables in my database. There are no spaces in any table names, they were originally first cap so I changed them to all lower case and still no go. Nothing seems to work - yet all the tables show as being installed by Dadabik. After install shows OK and I go to administration page, I get the page until the second list of tables and then the error. I get the error on the show all records - everything.

Our server has the magic_quotes settings set per requirements, however, there is not indication of what "register_globals" should be set to -- ours is turned "ON". Would this cause a problem? If so, what can I do to make the script work with this option turned on (can't turn it off site-wide because of other scripts on the site).

Can anyone help?
Thanks
Debbie
Eugenio
Re: Error [08]
March 16, 2004 09:57AM
Manfred Eggers wrote:

> I was too fast with my question.
>
> The problem was that my tables had blank spaces in the name
> of it.
> Dadbik 2.2.1 faced no prblem with it, but 3.0 does.
>
> So I used xxx_xxx instead and it worked.

You are right, this is a bug of version 3.0 beta, thanks for having reported it.
I've already fixed it, the fix will be available with the next release.



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Eugenio
Re: Error [08]
March 16, 2004 09:59AM
Debbie Sontag wrote:

> I'm getting this error on all the tables in my database.

[....]

Please turn $dubug_mode to 1 in config.php and report the error.



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Debbie Sontag
Re: Error [08]
March 16, 2004 04:32PM
After turning on $debug_mode to 1 and trying to view all records for the database, I get this:

[08] Error: during query execution.
SELECT name_field, present_insert_form_field, present_ext_update_form_field, present_search_form_field, required_field, present_results_search_field, present_details_form_field, check_duplicated_insert_field, type_field, other_choices_field, content_field, label_field, select_options_field, separator_field, primary_key_field_field, primary_key_table_field, primary_key_db_field, linked_fields_field, linked_fields_order_by_field, linked_fields_order_type_field, select_type_field, prefix_field, default_value_field, width_field, height_field, maxlength_field, hint_insert_field, order_form_field FROM dadabik_Problem_List ORDER BYorder_form_field
MySQL server said: You have an error in your SQL syntax near 'BYorder_form_field' at line 1

It's the same error I get no matter what table I attempt to view.

Debbie
Eugenio
Re: Error [08]
March 17, 2004 10:15AM
Debbie Sontag wrote:

> After turning on $debug_mode to 1 and trying to view all
> records for the database, I get this:

[....]

This is definetely a bug, thanks for having reported it, the bug applies only with MySQL version prior to 3.23.06.

To fix it, change line 112 of include/business_logic.php
from
$sql .= " ORDER BY".$quote."order_form_field".$quote."";
to
$sql .= " ORDER BY ".$quote."order_form_field".$quote."";



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Barry
Re: Error [08]
March 19, 2004 03:33AM
sorry I am getting the exact same error msg, and I am using 4.0.15-standard. I twas working fine until I upgraded to 3.0 beta
Eugenio
Re: Error [08]
March 19, 2004 10:53AM
Barry wrote:

> sorry I am getting the exact same error msg, and I am using
> 4.0.15-standard. I twas working fine until I upgraded to 3.0

Please turn $dubug_mode to 1 in config.php and report the error.


(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Barry
Re: Error [08]
March 19, 2004 03:00PM
oops and duhhh I feel dumb, my problem was the table name, they were two words..made it one and works great.
Tobi
Re: Error [08]
March 30, 2004 09:51PM
I had the same error. The error occures when i fill in a 'Primary key field'=id in the admin interface.

[08] Error: during query execution.
SELECT `applikation`.`id`, `applikation`.`name`, `applikation`.`Version`, `applikation`.`freigabeRef`, `applikation`.`tester`, `applikation`.`medienOK`, ``.`` FROM applikation LEFT JOIN `` ON `applikation`.`id` = ``.`id`
MySQL server said: Incorrect table name ''

And another Question: Do you still suggest to use the older version?

Tobi from Germany!

Alec Chambers
Re: Error [08]
April 08, 2004 09:53PM
Things were working fine for me until my hosting service upgraded to PHP 4.5.3 this morning. Show all and Search work fine, but I can no longer add records.

They di dwarn me that even minor upgrades can break scripts.

Eugenio
Re: Error [08]
April 11, 2004 01:32PM
Alec Chambers wrote:

> Things were working fine for me until my hosting service
> upgraded to PHP 4.5.3 this morning. Show all and Search work
> fine, but I can no longer add records.
>
> They di dwarn me that even minor upgrades can break scripts.

Could you specify the error message you get?



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Eugenio
Re: Error [08]
April 11, 2004 01:34PM
Tobi wrote:

> I had the same error. The error occures when i fill in a
> 'Primary key field'=id in the admin interface.

[....]

It seems that you haven't filled coorectly all the fields regarding foreign key feature in the admin interface, look at the documentation.



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Andrew
Re: Error [08]
April 23, 2004 09:12PM
Absolutely anything gives me an error. It can detect database/tables ok but 'select all' give error, see debug below.
MySql V3.23.49
PHP V4.3.4


DaDaBIK 3.0 Beta

[08] Error: during query execution.
SELECT `hosts`.`Host Name`, `hosts`.`IP`, `hosts`.`MAC` FROM hosts ORDER BY hosts.Host Name ASC LIMIT 0 , 10
MySQL server said: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'Name ASC LIMIT 0 , 10' at line 1.
Any suggestions.

Andrew
Re: Error [08]
April 23, 2004 09:27PM
Fixed error reported earlier by changing field name from Host Name to Host_Name, looks like DaDabik is not happy with spaces. I thinks this is a known issue as reported in another posting above..
thanks...
Alec Chambers
Re: Error [08]
May 03, 2004 01:16PM
Alec Chambers wrote:

> Things were working fine for me until my hosting service
> upgraded to PHP 4.5.3 this morning. Show all and Search work
> fine, but I can no longer add records.
>
> They di dwarn me that even minor upgrades can break scripts.

Could you specify the error message you get?

[08] Error: during query execution.

[Sorry about the delay in replying...]
Eugenio
Re: Error [08]
May 20, 2004 07:31PM
Alec Chambers wrote:

> Alec Chambers wrote:
>
> > Things were working fine for me until my hosting service
> > upgraded to PHP 4.5.3 this morning. Show all and Search
> work
> > fine, but I can no longer add records.
> >
> > They di dwarn me that even minor upgrades can break
> scripts.
>
> Could you specify the error message you get?
>
> [08] Error: during query execution.

Please turn $dubug_mode to 1 in config.php and report the error, post here the MySQL dump of all your db.
Which version of MySQL do you use?



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Heiko
Re: Error [08]
May 20, 2004 10:23PM
I get this error [8] when I want to use the "foreign key"-feature and the key field at the main-table has nothing value - it is NULL.
Then I get the error (from debug):
--- snip ---
SELECT `name` FROM `liefer` WHERE `lief` =
MySQL server said: You have an error in your SQL syntax near '' at line 1
--- snap ---

But I must say you make a very good featured tool to make little database-applications for the web.
Verry, verry wonderfoul.
Great!!!

Eugenio
Re: Error [08]
May 21, 2004 10:23AM
Heiko wrote:

> I get this error [8] when I want to use the "foreign
> key"-feature and the key field at the main-table has nothing
> value - it is NULL.

[....]

It's a strange situation: the primary key in the main table cannot be NULL, how is it possible?



(Latest version of DaDaBIK when this message was posted: 3.0 beta)
Sorry, only registered users may post in this forum.

Click here to login